Downgrade jose to version that works with rebar2 and del warning_as_error from it's config

pull/3154/head
Paweł Chmielowski 3 years ago
parent 5a927049ef
commit 948578b55b
  1. 7
      plugins/override_opts.erl
  2. 5
      rebar.config

@ -9,6 +9,11 @@ override_opts(add, Config, Opts) ->
lists:foldl(fun({Opt, Value}, Conf) ->
V = rebar_config:get_local(Conf, Opt, []),
rebar_config:set(Conf, Opt, V ++ Value)
end, Config, Opts);
override_opts(del, Config, Opts) ->
lists:foldl(fun({Opt, Value}, Conf) ->
V = rebar_config:get_local(Conf, Opt, []),
rebar_config:set(Conf, Opt, V -- Value)
end, Config, Opts).
preprocess(Config, _Dirs) ->
@ -24,6 +29,8 @@ preprocess(Config, _Dirs) ->
lists:foldl(fun({Type, AppName2, Opts}, Conf1) when
AppName2 == AppName ->
override_opts(Type, Conf1, Opts);
({Type, Opts}, Conf1a) ->
override_opts(Type, Conf1a, Opts);
(_, Conf2) ->
Conf2
end, C, TopOverrides);

@ -30,7 +30,7 @@
{jiffy, ".*", {git, "https://github.com/davisp/jiffy", {tag, "0.14.8"}}},
{p1_oauth2, ".*", {git, "https://github.com/processone/p1_oauth2", {tag, "0.6.5"}}},
{pkix, ".*", {git, "https://github.com/processone/pkix", {tag, "1.0.2"}}},
{jose, ".*", {git, "https://github.com/potatosalad/erlang-jose", {tag, "1.9.0"}}},
{jose, ".*", {git, "https://github.com/potatosalad/erlang-jose", {tag, "1.8.4"}}},
{eimp, ".*", {git, "https://github.com/processone/eimp", "172fae666e8da40142e9a17d9f9a154c6b697c9b"}},
{mqtree, ".*", {git, "https://github.com/processone/mqtree", {tag, "1.0.3"}}},
{if_var_true, stun, {stun, ".*", {git, "https://github.com/processone/stun", {tag, "1.0.28"}}}},
@ -148,6 +148,9 @@
{cover_export_enabled, true}.
{recursive_cmds, ['configure-deps']}.
{overrides, [
{del, [{erl_opts, [warnings_as_errors]}]}]}.
{post_hook_configure, [{"fast_tls", []},
{"stringprep", []},
{"fast_yaml", []},

Loading…
Cancel
Save