Outils pour Libre à vous !
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
Frédéric Couchet 624e9eac58 Ajout timestamps 3 weeks ago
..
0001-libavformat-ffmetadec-use-dynamic-allocation-for-lin.patch ajout du patch ffmpeg + fix path 3 years ago
README.md Correction date 2 months ago

README.md

Patch ffmpeg pour Libre à vous !

Pour le traitement des podcasts, il est utile d'avoir un ffmpeg patché (du moins tant que le patch n'a pas été intégré dans la version officielle). C'est mmu_man (François Revol qui a fait le patch). Il permet d'ajouter par un script l'image de cover à nos podcasts sans que l'image soit floue. Sinon, il faut utiliser un logiciel avec un interface graphique, par exemple Easytag.

J'ai mis en ligne le tarball du FFmpeg que j'avais patché et compilé en 2018 :

https://media.april.org/audio/radio-cause-commune/libre-a-vous/FFmpeg.tgz

Car visiblement le patch ne s'applique plus :

sudo apt install yasm

Prérequis

Pour pouvoir gére les PNG en Debian Stable :

apt-get install  zlib1g-dev

Pour pouvoir gérer la conversion en mp3

apt install libmp3lame-dev

Pour pouvor gérer la génération en ogg

apt install libogg-dev libvorbis-dev

Compilation

git clone https://github.com/FFmpeg/FFmpeg.git

cd FFmpeg

cd libavformat

# Pour être dans la version patchable :
git checkout d96ae9d5ea1f47a437fc0663b0cc26ff5d4d5d31

# Appliquer le patch : 
patch < path/to/0001-libavformat-ffmetadec-use-dynamic-allocation-for-lin.patch

cd ..

./configure --enable-libmp3lame --enable-decoder=png --enable-encoder=png --enable-libvorbis

make

Et si ça ne fonctionne pas ?

En cas de problème, peut-être cela vient-il des paramètres de ./configure. Tenter :

./configure --enable-libmp3lame --enable-decoder=png --enable-encoder=png